In order for the MealPlanMagic product to open and function properly, it must be used on a Computer with Microsoft Excel 2007 or later for Windows and Excel 2011 or greater for Mac.  This is also listed on our homepage.

You must use a desktop version, not OpenOffice, Office365, LibreOffice, or GoogleDocs.  Earlier versions may experience some loss of functionality. We are working on a mobile version.

If you meet these requirements and are still unable to open the product, please contact us for further troubleshooting.