Our tool currently requires Microsoft Excel 2007 or greater and to be used on a computer.  It works on both Mac and PC platforms.  We are working on a mobile version!